California Department of Transportation
Adobe


You need to have a minimum of Reader 8.2 or Acrobat 8.2 installed on your computer to use LiveCycle forms.

What version of Reader are you using?

Click the link below to install Adobe Reader.

Reader for Windows

 

  • Windows 2000 requires SP4 to install version 9.2.
  • Windows NT requires SP6 to install version 7.0.9, which may not allow for all form functionality to be used.
  • Mac OSX (PPC & Intel) requires 10.4.11 or above to install version 9.2.
  • Windows 95/98 users can only install up to Version 5.0.5, which will not display LiveCycle forms.
  • Linux users can get the appropriate versions from http://get.adobe.com/reader/otherversions/

 

Adobe and Reader are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries.

Last updated 12/17/2013